Article ID: 123942, created on Dec 16, 2014, last review on Mar 18, 2016

  • Applies to:
  • Plesk 11.0 for Linux
  • Plesk 10.4 for Linux/Unix


Plesk update on CentOS 5.x or RedHat 5.x from 10.4 to 11.0.9 fails with a Segmentation fault error.

/usr/local/psa/admin/bin/autoinstaller --select-release-id PLESK_11_0_9
Actual result that you got : Do you want to continue?
Type either Yes or No:
 [N]: Yes
Retrieving information about the installed packages...
Determining the packages that need to be installed.
Segmentation fault


This issue is caused by the internal autoinstaller package resolver.


Disable the internal autoinstaller package resolver by executing the following command:

echo 'USE_YUM="YES"' >> /root/.autoinstallerrc

This command forces autoinstaller to use yum instead of the internal resolver.

Search Words

autoinstaller segfault

unable to update

plesk update segmantaion fault

plesk upgrade Segmentation fault

a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c aea4cd7bfd353ad7a1341a257ad4724a 29d1e90fd304f01e6420fbe60f66f838 0a53c5a9ca65a74d37ef5c5eaeb55d7f e8756e9388aeca36710ac39e739b2b37 dd0611b6086474193d9bf78e2b293040

Email subscription for changes to this article
Save as PDF