Article ID: 124423, created on Feb 8, 2015, last review on Feb 8, 2015

  • Applies to:
  • Plesk 12.0 for Linux
  • Plesk 11.5 for Linux


We have added additional custom php versions on the server and registered them with Plesk correctly.

~# plesk sbin php_handlers_control --list
            id:  display name:  version:    type:                     cgi-bin:  cli-bin:                     php.ini:
         module         5.3.10    5.3.10   module            /usr/bin/php5-cgi                  /etc/php5/cgi/php.ini
        fastcgi         5.3.10    5.3.10  fastcgi            /usr/bin/php5-cgi                  /etc/php5/cgi/php.ini
            cgi         5.3.10    5.3.10      cgi            /usr/bin/php5-cgi                  /etc/php5/cgi/php.ini
 Custom-5.4.37-fcgi      Custom-5.4.37    5.4.37  fastcgi  /opt/php-5.4.37/bin/php-cgi            /opt/php-5.4.37/etc/php.ini
 Custom-5.5.21-fcgi      Custom-5.5.21    5.5.21  fastcgi  /opt/php-5.5.21/bin/php-cgi            /opt/php-5.5.21/etc/php.ini

When we change the FastCGI PHP version to one of the additional versions nothing changes

Additional packages integrity verification shown the following:

For RPM based systems:

# rpm -V psa-php5-configurator

S.5....T.    /var/www/cgi-bin/cgi_wrapper/cgi_wrapper 

For DEB based systems:

# debsums psa-php5-configurator
/usr/lib/plesk-9.0/fix_php_session_dir_perms_trigger                          OK
/var/www/cgi-bin/cgi_wrapper/cgi_wrapper                                  FAILED


Invalid cgi_wrapper binary, which is responsible for handling custom PHP versions


Replace the corrupted binary with the valid one from psa-php5-configurator package.

Search Words

php handlers

handlers not working

a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c 01bc4c8cf5b7f01f815a7ada004154a2 29d1e90fd304f01e6420fbe60f66f838 0a53c5a9ca65a74d37ef5c5eaeb55d7f 2a5151f57629129e26ff206d171fbb5f e335d9adf7edffca6a8af8039031a4c7

Email subscription for changes to this article
Save as PDF