Article ID: 125404, created on May 2, 2015, last review on Jun 17, 2016

  • Applies to:
  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux
  • Plesk 11.5 for Linux


Changing php memory limit through PHP Selector not working under CageFS environment.


This happenes when package CageFS is installed and enabled for all users.


Disable CageFS to fix the issue:

# cagefsctl --disable-all

It is recommended to manage php parameters of a domain through Plesk:

Home > Subscription > > Websites & Domains > > PHP Settings

To manage multiple php versions on the server please use the KB article #118378.

Search Words

php version not available

Failed to write session data

Url of page experiencing the issue: Username/password: Steps to reproduce the issue: is built on the joomla platform. We are nto able to upload extensions into joomla. When we try we get an error that zlib is not installed. General description: On we have an extension in plesk that allows us to change the version of php for each domain. We have a subscription named Inside that are three domains. (live site) (testing site) and (new site under development). is on 5.3 and needs to stay on 5.3. in on 5.4.28 which is correct. But I am not able to enable zlib or any of the other php extensions. in plesk when I go to PHP selector I see that its is check ed for version 5.4, but for some reason it is not actually turing on.

Enabling PHP Selector

a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c 29d1e90fd304f01e6420fbe60f66f838 01bc4c8cf5b7f01f815a7ada004154a2 0a53c5a9ca65a74d37ef5c5eaeb55d7f 2a5151f57629129e26ff206d171fbb5f e335d9adf7edffca6a8af8039031a4c7 742559b1631652fadd74764ae8be475e

Email subscription for changes to this article
Save as PDF