Article ID: 125431, created on May 5, 2015, last review on Jun 17, 2016

  • Applies to:
  • Plesk 11.5 for Linux


Unable to register PHP4.3.9 as an additional PHP handler. PHP handler registration fails with the following error:

~# /usr/local/psa/bin/php_handler --add-displayname 4.3.9 -path /usr/local/php4/bin/php -phpini /usr/local/lib/php.ini -type cgi

2013-09-25T14:39:09-07:00 ERR (3) [util_exec]: proc_close() failed
Unable to register the PHP handler: can not get version from /usr/local/php4/bin/php

However PHP4.3.9 does appear to be installed correctly:

~# /usr/local/php4/bin/php -v
PHP 4.3.9 (cgi-fcgi) (built: Sep 26 2013 10:28:09)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies


The issue is caused by the PHP source code - when checking version it was written to return 'error' exit codes - exit(1) - at any time.

Fix was implemented in PP11.5 MU#24


Make sure the latest product update is installed:

# /usr/local/psa/admin/bin/autoinstaller --select-product-id panel  --select-release-current    --reinstall-patch --install-component base

Search Words

unable to register the php handler

can not get version

Unable to register the PHP handler

29d1e90fd304f01e6420fbe60f66f838 56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 01bc4c8cf5b7f01f815a7ada004154a2 0a53c5a9ca65a74d37ef5c5eaeb55d7f

Email subscription for changes to this article
Save as PDF