Article ID: 126092, created on Jul 6, 2015, last review on Oct 18, 2016

  • Applies to:
  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux


Attempting to update Atomic ModSecurity rule set results in error:

Error message or request description : Error: Failed to update the ModSecurity rule set: modsecurity_ctl failed: gpg: key 4520AFA9: "Atomicorp (Atomicorp Official Signing Key) <>" not changed 
gpg: Total number processed: 1 
gpg: unchanged: 1 
gpg: Signature made Tue Jun 23 00:10:58 2015 EEST using RSA key ID 4520AFA9 
gpg: Good signature from "Atomicorp (Atomicorp Official Signing Key) <>" 
gpg: WARNING: This key is not certified with a trusted signature! 
gpg: There is no indication that the signature belongs to the owner. 
Primary key fingerprint: 1818 66DF 9DAC A40E 5B42 9B08 FFBD 5D0A 4520 AFA9 
TERM environment variable not set. 
aum failed with exitcode 3. 

Checking versions ... 

ASL version is current:  [PASS] 

Authorization failed attempting to download an update. 
The username or password may be invalid, or your license may be expired. 
Please log in to the License Manager at
mber/member.php and verify your account. 

Further information may be found at: 
Errors were encountered: 
- ---- ----------------------------- ------------------------------------------  
[0;33m2 302 Core::distributed_update remote fail: E_GEN_RETRY 22 .. www3.atomic -201506230902.tar.bz2  
[0m [1;31m3 303 Core::distributed_update Invalid user credentials  [0m 

Unable to download tortix rule set


Incorrect username/password or license is expired.


Clear or just move the contents of the directory /var/asl/rbc/etc/asl/config.

Check username/password in /etc/asl/config configuration file.

In case using Atomic ModSecurity (subscription) rule set log in to the Atomic License Manager and verify the account. Ensure that credentials used in Plesk to download Atomic ModSecurity ruleset are valid.

Further information can be found on Atomic website.

If Atomic Professional ModSecurity rule set is used and additional license key is not expired, please contact Technical support.

Search Words

Authorization failed attempting to download an update


Atomic Professional ModSecurity


Mod Security error

modsecurity_ctl failed

Failed to update the ModSecurity rule set

Invalid user credentials

invalid user credentials

29d1e90fd304f01e6420fbe60f66f838 56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 2a5151f57629129e26ff206d171fbb5f e335d9adf7edffca6a8af8039031a4c7 742559b1631652fadd74764ae8be475e

Email subscription for changes to this article
Save as PDF