Article ID: 127336, created on Nov 4, 2015, last review on Nov 4, 2015

  • Applies to:
  • Plesk 12.0 for Windows


  • Sites showing 'The FastCGI executable could not be found' error when php handler changed to newer php version.
  • Plesk was not completely upgraded The FastCGI executable could not be found


Required PHP binary is missing.


  1. Install older PHP version once again "C:\ParallelsInstaller\parallels\PANEL-WIN_12.0.18\dist-msi-Microsoft-2003-i386\plesk-engine.msi"

  2. Move all your websites on newer php version

  3. Later, If you want you can remove older PHP versions

Search Words


The FastCGI executable could not be found

php handler

ed7be2b984f9c27de1d2dc349dc19c6d 56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 85a92ca67f2200d36506862eaa6ed6b8 a766cea0c28e23e978fa78ef81918ab8

Email subscription for changes to this article
Save as PDF