Article ID: 127896, created on Dec 26, 2015, last review on Dec 29, 2015

  • Applies to:
  • Plesk for Linux/Unix


Plesk update failed on CentOS 5. The similar message can be found in /var/log/plesk/install/autoinstaller3.log:

YumGPGCheckError: Problem opening package
error: rpmts_HdrFromFdno: Header V4 RSA/SHA1 signature: BAD, key ID 4520afa9
Fatal error during packages installation: Problem opening package
YumGPGCheckError: Problem opening package

Atomic repository is enabled:

 # yum repolist
 atomic          CentOS / Red Hat Enterprise Linux 5 -  


Atomic repository issues.


As workaround, the following steps can be done:

  1. Download mysql, mysql-libs, mysql-server via yumdownloader (it is part of yum-utils package):

    # yumdownloader --nogpgcheck mysql.x86_64 mysql-libs.x86_64 mysql-server.x86_64
  2. Remove bad signatures from this packages:

    # rpm --delsign
    # rpm --delsign
    # rpm --delsign
  3. Install packages via rpm:

    # rpm -Uvh
    # rpm -qa | grep mysql

Another way is temporary disable Atomic repository.

This issue is on Atomic side, additional information can be found here.

Search Words

YumGPGCheckError: Problem opening package



Header V4 RSA/SHA1 signature

Failed to run the Yum utility.

BAD, key ID

56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838

Email subscription for changes to this article
Save as PDF