Article ID: 128006, created on Jan 10, 2016, last review on Jan 10, 2016

  • Applies to:
  • Plesk 12.0 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux


Unable to upgrade Plesk on Debian/Ubuntu. Got following error while upgrade:

    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    libpam-plesk : Depends: sw-mariadb-client but it is not going to be installed


Unresolved dependencies.


  1. Fix all broken dependencies automatically:

    # apt-get -f install
  2. Force Plesk Installer to override detected operating system version:

    # /usr/local/psa/admin/sbin/autoinstaller --override-os-version 7

Search Words

Plesk Automatic Update fail

You might want to run 'apt-get -f install' to correct these

You might want to run 'apt-get -f install'

a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c 29d1e90fd304f01e6420fbe60f66f838 01bc4c8cf5b7f01f815a7ada004154a2 0a53c5a9ca65a74d37ef5c5eaeb55d7f aea4cd7bfd353ad7a1341a257ad4724a 2a5151f57629129e26ff206d171fbb5f e335d9adf7edffca6a8af8039031a4c7

Email subscription for changes to this article
Save as PDF