Article ID: 128132, created on Jan 21, 2016, last review on Jun 17, 2016

  • Applies to:
  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows


Unable to activate/update/download rules from Atomic Professional ModSecurity ruleset.

On Linux:
The following error can be found in /var/log/plesk/panel.log with enabled debug:

ERR [util_exec] proc_close() failed ['/usr/local/psa/admin/bin/modsecurity_ctl' '--install' '--with-backup' '--ruleset' 'tortix'] with exit code [1]

Unable to download tortix rule set

ERR [1] PleskUtilException: '/usr/local/psa/admin/bin/modsecurity_ctl' '--install' '--with-backup' '--ruleset' 'tortix' failed with code 1.

Manual execution leads to the following:

# aum -u

Errors were encountered:

L CODE SOURCE                        MESSAGE
- ---- ----------------------------- ------------------------------------------
2 9998 Core::_get_license_key        Invalid key data
2 9998 Core::_get_license_key        Invalid key data

Also Apache service is down.

On Windows:

The following error appears during activation of rule set:

Error: Failed to update the ModSecurity rule set modsecuritymng failed: Error sending request 'channels/rules/subscription/VERSION' to '': status 401


  1. Open Plesk > Tools & Settings > License Management > Additional License Keys

  2. Open key for Atomic ModSecurity and click Retrieve Additional Key button.

  3. Go to Plesk > Tools & Settings > Web Application Firewall > Atomic Professional ModSecurity > Apply.

Search Words


Atomic Professional ModSecurity

Unable to download tortix rule set

742559b1631652fadd74764ae8be475e 56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 e335d9adf7edffca6a8af8039031a4c7 8b661cab116c79dbe6c4ac5bbdf1c8cb 85a92ca67f2200d36506862eaa6ed6b8 a766cea0c28e23e978fa78ef81918ab8 2a5151f57629129e26ff206d171fbb5f

Email subscription for changes to this article
Save as PDF