Article ID: 128472, created on Feb 26, 2016, last review on Feb 26, 2016

  • Applies to:
  • Plesk 12.5 for Linux


Plesk upgrade fails with Segmentation fault error:

File downloading PMM_0.1.10/pmm-0.1.10-cos6-x86_64.inf3: 33%..100% was finished.
gpg-pubkey-914bdf7e-55c05220 gpg(Plesk Team <>)
gpg-pubkey-c105b9de-4e0fd3a3 gpg(CentOS-6 Key (CentOS 6 Official Signing Key) <>)
Segmentation fault

There were failed attempts to upgrade Plesk earlier and its packages belongs to different Plesk versions.

If Plesk upgrade started in debug mode /usr/local/psa/admin/bin/autoinstaller --debug the following error occurs in /tmp/autoinstaller3.log :

[2016-02-26 12:46:08.087681] Impl: /usr/local/psa/bin/extension --get-xml-info heavy-metal-skin
[2016-02-26 12:46:08.219712] DEBUG detect extension package ext-heavy-metal-skin version: The file /usr/local/psa/bin/extension is part of Plesk distribution. It cannot be run outside of Plesk environment.


sw-engine package belongs to previous version of Plesk


  1. Download appropriate version of sw-engine package from , e.g. for Plesk 12.5.30 and CentOS 6:

    # wget
  2. Upgrade sw-engine package as follows:

    # rpm -Uvh sw-engine-2.16.2-centos6.201510051436.x86_64.rpm --nodeps
  3. Restart upgrade using Plesk autoinstaller:

    # /usr/local/psa/admin/bin/autoinstaller

Search Words

The file /usr/local/psa/bin/extension is part of Plesk distribution.

Plesk upgrade fails with Segmentation fault error

742559b1631652fadd74764ae8be475e 56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 e335d9adf7edffca6a8af8039031a4c7

Email subscription for changes to this article
Save as PDF