Article ID: 1471, created on Oct 6, 2008, last review on May 10, 2014

  • Applies to:
  • Panels
  • Virtuozzo containers for Windows

Symptoms

A service does not start. In the event logs, events 7000 and 7011 are logged in Windows Server 2003. When you start the Virtuozzo Hardware Node (HN), the service does not start, and the following error events appear in the Application log:

Event 1

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7000

The ServiceName service failed to start due to the following error: The service did not respond to the start or control request in a timely fashion.
 
Event 2

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7011
Description: Timeout (30000 milliseconds) waiting for a transaction response from the ServiceName service.

Cause

In the event of a high load, these problems may occur.

Resolution

The solution below is to be applied if a service does not start on the Hardware Node itself:

To work around this problem, you should modify the registry to increase the default timeout value for the service control manager. To increase this value to 60 seconds, follow these steps:

1. Click Start, click Run, type regedit, and then click OK.

2. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control

3. In the right pane, locate the ServicesPipeTimeout entry.
Note: If the ServicesPipeTimeout entry does not exist, you must create it. To do this, follow these steps:

a. On the Edit menu, point to New, and then click on the DWORD value.
b. Type ServicesPipeTimeout, and then press ENTER.

4. Right-click ServicesPipeTimeout, and then click Modify.

5. Click Decimal, type 60000, and then click OK. This value represents the time in milliseconds before a service times out.

6. Restart the computer.

Note: This workaround may resolve a problem in which a service does not start. However, we recommend that you research this problem to determine whether it is a symptom of another problem. Refer to the original Microsoft article on this subject.

The solution below is to be applied if a service does not start inside containers:

In order to increase the timeout for containers, it is necessary to do the following:

1. Open the C:\Program Files\SWsoft\Virtuozzo\bin\on_vps_startup.cmd file in Notepad.

2. Find this string:

    reg add "HKLM\vz%VPSID%\MACHINE\SYSTEM\CurrentControlSet\Control" /v ServicesPipeTimeout /t REG_DWORD /d 120000 /f

3. Increase the ServicesPipeTimeout value (for example, to 360000).

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