Article ID: 1721, created on Feb 28, 2007, last review on Apr 17, 2012

  • Applies to:
  • Plesk for Linux/Unix

Resolution

SYMPTOMS:

If you run autoinstaller and choose Tomcat component to be installed, installation fails with:

--->  Installing 'diablo-jdk-1.5.0.07.01' from a port (java/diablo-jdk15)
--->  Building '/usr/ports/java/diablo-jdk15'
=> diablo-caffe-freebsd6-i386-1.5.0_07-b01.tar.bz2 doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch from
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/ports/distfiles/ and try again.
*** Error code 1


CAUSE:

Some packages require manual download via browser due to license restriction, so autoinstaller fails to download them.


RESOLUTION:


 Go to /usr/ports/java/diablo-jdk15 and run `make fetch`  to get download inctructions:

 # make fetch
===>  diablo-jdk-1.5.0.07.01_1 :
 Because of licensing restrictions, you must fetch the distribution
 manually.  Please access

 http://www.FreeBSDFoundation.org/cgi-bin/download?download=diablo-caffe-freebsd6-i386-1.5.0_07-b01.tar.bz2

 with a web browser and "Accept" the End User License Agreement for
 "Caffe Diablo 1.5.0".  Please place the downloaded
 diablo-caffe-freebsd6-i386-1.5.0_07-b01.tar.bz2 in /usr/ports/distfiles.


Please download the files that are listed in the error manually via browser and place them into /usr/ports/distfiles. Then start Plesk installation again.

29d1e90fd304f01e6420fbe60f66f838 a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF