Article ID: 1863, created on May 22, 2007, last review on May 11, 2014

  • Applies to:
  • Plesk for Linux/Unix

Symptoms

Plesk upgrade fails displaying the following error:

Product: Plesk 7.6.1 for Microsoft Windows -- Error 1713. Plesk 7.6.1 for Microsoft Windows cannot install one of its required products. Contact your technical support group.  System Error: 1605.

Cause

The most possible reason of the problem is that one of .msi files in c:\windows\installer folder is missing.

Resolution

1.Enable logging during upgrade 

plesk_distributive.exe /l*v c:\plesk.log


2.When the error is displayed do not click OK  and open c:\plesk.log 

3.The full error text should look like the following:

MSI (s) (E8:48) [05:02:25:203]: Warning: Local cached package  C:\WINDOWS\Installer\17b2a8.msi' is missing.MSI (s) (E8:CC) [05:02:25:203]: Note: 1: 1713 2: Plesk 7.6.1 for Microsoft Windows 3: 1605 DEBUG: Error 2888:  Executing the Binary view failedInternal Error 2888. BinaryMSI (c) (F8:A4)
[05:18:03:968]: Disallowing shutdown.  Shutdown counter: 0
MSI (s) (E8:CC)
[05:18:03:984]: Product: Plesk 7.6.1 for Microsoft Windows -- Error 1713. Plesk 7.6.1 for Microsoft Windows cannot install one of its required products. Contact your technical support group.  System Error: 1605.
 

4.Open regedit and find 17b2a8.msi record. It should be found under the registry key like this:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\ECEC1F2E33959844DA4EC2D6178D2B3F\InstallProperties


5.Delete the whole parent registry entire (export it before just in case):

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\ECEC1F2E33959844DA4EC2D6178D2B3F


6.Run Plesk upgrade again.

a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF