Article ID: 2191, created on Sep 25, 2007, last review on May 10, 2014

  • Applies to:
  • Plesk for Linux/Unix


Such error means that the packet contains errors or it's version is not compatible with current protocol version that is used by Plesk.


XML packet can be validated using 'xmllint' command that belongs to 'libxml2' package, run on Plesk server:

xmllint -schema $PRODUCT_ROOT_D/admin/htdocs/schemas/rpc/PROTOCOL_VERSION/agent_input.xsd FILE.xml

Where $PRODUCT_ROOT_D/admin/htdocs/schemas/rpc/PROTOCOL_VERSION/agent_input.xsd  is scheme file for the appropriate protocol version.

Also, for checking XML syntaxis and vier XML packet in comfortable format you can use:
# xmllint --format FILE.xml

Another way, you can enable error reporting on Plesk server where you are sending API request to. Set "display_errors = On" in "$PRODUCT_ROOT_D/admin/conf/php.ini" and restart Plesk CP. After that run API request again. More detailed error should be returned in API response and can be found in "$PRODUCT_ROOT_D//admin/logs/httpsd_error_log" on Plesk server.

29d1e90fd304f01e6420fbe60f66f838 a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF