Article ID: 3543, created on Dec 29, 2007, last review on Apr 2, 2015

  • Applies to:
  • Plesk 8.3 for Linux/Unix


I run upgrade using Autoinstaller but it stops with the error, even if the license is up to dated:

ERROR: Failed to check whether a new license key is available. The installation will not continue.


The problem appears with Autoinstaller 3.3.0 that was released with the very first build of Plesk 8.3.0 version. It has been fixed in the next autoinstaller 3.3.0 build, that may be downloaded from Plesk 8.3.0 download page.


Download fresh autoinstaller (build is equal or greater then v3.3.0 build071228.14) that corresponds to your OS version and replace /usr/local/psa/admin/sbin/autoinstaller and /usr/local/psa/bin/autoinstaller files with new one

For example for CentOS 5 i386:

# wget
# cp swsoft_installer_v3.3.0_build080116.12_os_CentOS_5_i386 /usr/local/psa/bin/autoinstaller
# cp swsoft_installer_v3.3.0_build080116.12_os_CentOS_5_i386 /usr/local/psa/admin/sbin/autoinstaller
# chmod 755 /usr/local/psa/admin/sbin/autoinstaller /usr/local/psa/bin/autoinstaller
# chown root:root /usr/local/psa/admin/sbin/autoinstaller /usr/local/psa/bin/autoinstaller

a914db3fdc7a53ddcfd1b2db8f5a1b9c b8ef5052d936e902043e41759118114e 29d1e90fd304f01e6420fbe60f66f838 9f8b3267dc294b8e42f097f7cddbc524 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF