Article ID: 3546, created on Jan 7, 2008, last review on May 10, 2014

  • Applies to:
  • Plesk for Linux/Unix


Plesk installation or upgrade on CentOS failed with the error in console:

ERROR while trying to install initial Plesk database

Installation log shows:

Trying to install initial Plesk database... ERROR 1064 (42000) at
line 2: You have an error in your SQL syntax; check the manual that
corresponds to your MySQL server version for the right syntax to use near
'----------------------------------------' at line 1


The 5.0.54 version of MySQL is no longer accepting SQL comment lines that begin with '--', and that do not have a whitespace or control character after the '--' string.  This worked in previous MySQL releases even though the MySQL team explicitly stated that it was not supported (


Take previous mysql* rpms from centosplus repository, like  and downgrade mysql to older version, for example 5.0.48. Then run Plesk upgrade/installation again. This issue will be fixed in further Plesk versions.

29d1e90fd304f01e6420fbe60f66f838 a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF