Article ID: 3594, created on Feb 4, 2008, last review on May 9, 2014

  • Applies to:
  • Virtuozzo containers for Windows


Parallels Virtuozzo Containers 4.0 Agent is compatible with 3.5.1 Agent by default. This means that any tools that use the old API and connection method, such as Parallels Business Automation (formerly HSPComplete) or VZMC (Management Console from the 3.5.1 version), can work with Parallels Virtuozzo Containers 4.0.

Compatibility mode enables the vzaopcompat service on HW Nodes that allows you to manages NW Nodes through the SSH protocol and Vituozzo 3.5.1 API. Since the 4.0 version, Nodes are managed via the SSL protocol.

Compatibility mode is enabled by default and does not require any additional configuration. However, keep the following in mind:

- If you upgrade Virtuozzo 3.5.1 to Parallels Virtuozzo Containers 4.0, the vzagent0 password is taken from the 3.5.1 installation.

- If you install Parallels Virtuozzo Containers 4.0 on a fresh server, the password for the vzagent0 account is set randomly and needs to be reset, providing that compatibility is required. You can do this by using the following command:

vzctl exec 1 net user vzagent0 <new_password>

Note: If it is necessary to reinstall Service Container, do not forget to enable compatibility mode during reinstallation.

965b49118115a610e93635d21c5694a8 d02f9caf3e11b191a38179103495106f 2897d76d56d2010f4e3a28f864d69223

Email subscription for changes to this article
Save as PDF