Article ID: 3952, created on Feb 18, 2008, last review on May 10, 2014

  • Applies to:
  • Plesk 8.3 for Linux/Unix


If you use protocl version lesser than 1.4.2 in XML API request, the following error occurs:

                        <errtext>Parser error: Request is invalid</errtext>
Element '{}complexType': The type has an 'all'
model group in its {content type} and thus cannot be derived from a non-empty
type, since this would produce a 'sequence' model group containing the 'all'
model group; 'all' model groups are not allowed to appear inside other model
groups. in............


There are two solutions for this problem. The first, update Plesk 8.3 to patch 2.
And the second, use protocol version 1.4.2 or greater in XML API requests, however in this case make sure that all your API requests are compatible with used protocol version.

9f8b3267dc294b8e42f097f7cddbc524 b8ef5052d936e902043e41759118114e 29d1e90fd304f01e6420fbe60f66f838 a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF