Article ID: 4021, created on Mar 19, 2008, last review on Apr 16, 2012

  • Applies to:
  • Sitebuilder 3.x for Linux/Unix


Error message looks like this one:

Internal SiteBuilder error.
File: /usr/local/opt/sitebuilder/include/SB/Site/PublicationList.php; Line: 420
Message: Invalid template 'vap-29'; Code: 0

Template name can be different.


Most probably issue related to different color schemes on site and in template. This situation can appear after migration from version 2.x to 3.x or from version 2.x to 4.x.


It is necessary to check if appropriate color scheme is set on the site. For this need to figure out color scheme for site and template which is used on the site:

mysql> select color_scheme, template_id from site where alias like 'SITE_ALIAS';
| color_scheme | template_id |
| color5       |         ID  |

1 rows in set (0.00 sec)


You will get COLOR and ID. After that available colors for template with id which you get should be checked:

mysql> select schemes from template where id = ID;
| schemes                  |
| color1 | color2 | color3 |

1 rows in set (0.00 sec)


If COLOR is not the one of these colors, site information should be updated with one of the available template's colors:

mysql> update site set color_scheme = 'color1' where alias='SITE_ALIAS';

When information will be updated site should be checked one more time.

bc0c0e819a57401467405ce3003b8d5e d055be4fdc562a8ecb8e6d0bf419f946 fad6dc0c8e983c17ae70a51ac7952cd0 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF