Article ID: 5388, created on Jun 24, 2008, last review on Aug 12, 2014

  • Applies to:
  • Plesk Sitebuilder for Linux/Unix


 Following error outputted in Sitebuilder:

Internal SiteBuilder error.
File: /usr/local/sitebuilder/include/SB/Site/ModuleInstancesList.php; Line: 76
Message: Module with instance id='MODULE_INSTANCE_ID' does not exists.; Code: 0


Try to make following changes to resolve this situation for particular issued site:

1. Figure out where site content is stored on Sitebuilder server:

Log into mysql database and run following query:

mysql> select dir_name from where alias='SITE_NAME';

For example, you get something like this: 6481275f1cacad4cfef4dda324053855. Make backup for /usr/local/sitebuilder/htdocs/sites/64/6481275f1cacad4cfef4dda324053855/
directory (on Debain server path will be different /opt/sitebuilder/..) and check the files which contains ID for module which does not exists:

Creating backup, just in case:

# cp -rp /usr/local/sitebuilder/htdocs/sites/64/6481275f1cacad4cfef4dda324053855/ /usr/local/sitebuilder/htdocs/sites/64/6481275f1cacad4cfef4dda324053855_saved

Looking for missing module instance id:

# grep -r MODULE_INSTANCE_ID /usr/local/sitebuilder/htdocs/sites/64/6481275f1cacad4cfef4dda324053855/

When you find the file which contains this note, delete <iframe> section from it with MODULE_INSTANCE_ID, starting from <iframe and ending by </iframe>.


This situation completely resolved in 4.0.0 version + sitebuilder_patch_4.0..0.3.tgz which should be applied on 4.0.0 installation. This patch can be taken from here
In later 4.1 and 4.2 versions this situation also corrected. If you meet this issue on 4.0.0+patch3 or later installations it means that issue came from older versions with upgrade. In this case it is suggested to perform actions described in this article upper.

d055be4fdc562a8ecb8e6d0bf419f946 fad6dc0c8e983c17ae70a51ac7952cd0 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF