Article ID: 5460, created on Jul 10, 2008, last review on Aug 12, 2014

  • Applies to:
  • Plesk Sitebuilder 4.x for Linux/Unix


The following error appears when I try to publish the site with Parallels Plesk Sitebuilder 4.5:

The site cannot be published to the specified location.
The specified site location does not support modules data storage. SQLite version 2.x must be installed at the target server. Please contact the server administrator.


There is list of Published Sites Server Requirements for publishing sites with Sitebuilder:

Parallels Plesk SiteBuilder 4.5 for Linux/Unix:

    Any Linux/Unix OS
    Apache web server (any version)
    PHP >= 4.3.9 (mail support should work)
    PHP extensions:
        Ioncube >= 3.1.15
        domxml_xslt or xslt
        sqlite (2.x, support UTF-8 encoding)
        gd >=2 0 (with support PNG, GIF, JPG, BMP formats)

This list includes PHP extension sqlite (2.x, support UTF-8 encoding). If the site does not have the appropriate SQLite 2.x extension installed for PHP, you will get an error message during publication.


Parallels provides packages php-sqlite2 - PHP extension for SQLite 2 with UFT-8 support.

The package name is php-sqlite2 or php53-sqlite2 - available in the Plesk 9.5.4 repository, in subdirectory "contrib". Here are the extensions for different PHP versions:

SQLite2 extension for PHP 5.0

SQLite2 extension for PHP 5.1

SQLite2 extension for PHP 5.2

SQLite2 extension for PHP 5.3

Alternatively you may compile the PHP extension fir SQLite 2 with UFT-8 support by yourself.

Additional Information

Does SiteBuilder support SQLite 3.x?

Warning about UTF-8 encoding support for SQLite

Search Words

sqlite (2.x, support UTF-8 encoding)


SQLite version 2.x must be installed at the target server

fad6dc0c8e983c17ae70a51ac7952cd0 56797cefb1efc9130f7c48a7d1db0f0c d055be4fdc562a8ecb8e6d0bf419f946 ea6a61e571a858aa6019ceb068ea403a

Email subscription for changes to this article
Save as PDF