Article ID: 5461, created on Jul 10, 2008, last review on May 11, 2014

  • Applies to:
  • Plesk Sitebuilder 4.x for Linux/Unix


There is a special requirements list for publishing server:

To guarantee correct operation of dynamic sites, make sure that the publishing server meets the following requirements:

- PHP version 4.3.9 or later is installed on the publishing server.
- PHP supports:
    - The ionCube PHP Loader 3.1.15 or later
    - DOM XML with XSLT support or PHP XSLT extension (Sablotron)
    - Multibyte string functions (mbstring extension)
    - Zlib compression functions (zlib extension)
    - Session handling functions support (session extension)
    - SQLite 2.x with UTF-8 encoding support
    - GD library 2.0.1 or later 
- In php.ini the following directive is installed:
    - default_charset = "UTF-8"

    Note: Make sure that all extensions you have installed are listed in the extensions directory and in the php.ini file. If PHP is installed as an Apache module, restart Apache after applying the changes.

This list includes SQLite (2.x, support UTF-8 encoding) support for PHP. If publishing side does not have appropriate SQLite 2.x extension installed for PHP you will get error message during publication.

SQLite 3.x is not supported by Parallels Plesk Sitebuilder 4.5.

Related Articles

[Info] SiteBuilder fails to publish because of missing SQLite 2.x support

Search Words

requirements to publishing host

does Sitebuilder support sqlite3

sqlite 3

fad6dc0c8e983c17ae70a51ac7952cd0 56797cefb1efc9130f7c48a7d1db0f0c ea6a61e571a858aa6019ceb068ea403a d055be4fdc562a8ecb8e6d0bf419f946

Email subscription for changes to this article
Save as PDF