Article ID: 5492, created on Jul 23, 2008, last review on May 10, 2014

  • Applies to:
  • Odin Business Automation Standard 4.x
  • Plesk Sitebuilder 4.5 for Linux/Unix
  • Sitebuilder 4.5 for Windows


I successfully uploaded an image using option "Image Upload" into Image Gallery on my site. But when view the site in site preview the image is not shown but blank space instead, however upload was successful and the image exist on Sitebuilder server.


When new image is uploaded into Image Gallery it is renamed and immediately goes to the publishing location, %domain.tld%. Sitebuilder site preview uses the following link for the image to show it:


In case hostname %domain.tld% is not resolved globally the image is not shown but an empty space occurs.


Make %domain.tld% be globally resolvable. As a workaround you may configure host name data base on your workstation. Add the appropriate record into file /etc/hosts for Unix/Linux operating systems or into C:\WINDOWS\system32\drivers\etc\hosts for Windows.

%IP_Address% %domain.tld%

Where %IP_Address% is real IP address of domain name %domain.tld% the site should be accessible on the web.

Search Words

image gallery

image is missing

Image gallery

Errors uploading to SiteBuilder Image Gallery

image is not visible

fad6dc0c8e983c17ae70a51ac7952cd0 56797cefb1efc9130f7c48a7d1db0f0c 5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 2a62cbceb986d1b8f45bcd3ff4cb29a5 400e18f6ede9f8be5575a475d2d6b0a6 70a5401e8b9354cd1d64d0346f2c4a3e f7f840260c1591440648a375a64b5b75 d055be4fdc562a8ecb8e6d0bf419f946 ea6a61e571a858aa6019ceb068ea403a 2554725ed606193dd9bbce21365bed4e 4d336e73be6d8fa81454b57cedf8e2bb 45e8c8798afdb3e279a2f84bd498d19e 614fd0b754f34d5efe9627f2057b8642

Email subscription for changes to this article
Save as PDF