Article ID: 6089, created on Feb 27, 2009, last review on Aug 12, 2014

  • Applies to:
  • Plesk Sitebuilder 4.5 for Linux/Unix


The following message occurs when try to open a site in Sitebuilder Wizard (Sites > %site name% > Open Site In Wizard):

Internal Sitebuilder error.
File: /opt/sitebuilder/include/Base/ORM/Object.php; Line: 105
Message: Unknown method with name 'isDinamicCode'; Code: 0


Script /usr/local/sitebuilder/include/Modules/Script.php (/opt/sitebuilder/include/Modules/Script.php for Debian/Ubuntu) is outdated. The issue affects all sites that use Sitebuilder module Script.


Valid Script.php for Parallels Plesk Sitebuilder 4.5.0 is attachment.

To install it: extract the script from the archive attached and replace existent file /usr/local/sitebuilder/include/Modules/Script.php (/opt/sitebuilder/include/Modules/Script.php for Debian/Ubuntu). Remember correcting owner and permissions:

~# chown root:root /usr/local/sitebuilder/include/Modules/Script.php
~# chmod 644 /usr/local/sitebuilder/include/Modules/Script.php

Remember saving the old file Script.php (just in case).

Remember re-installing Sitebuilder updates. Login to Parallels Plesk Sitebuilder as admin and change to Server > Autoupdate. Click Roll Back All Updates and wait while the updates are removing. Then click Install to install updates back.

Search Words

Unknown method with name 'isDinamicCode'



fad6dc0c8e983c17ae70a51ac7952cd0 56797cefb1efc9130f7c48a7d1db0f0c f7f840260c1591440648a375a64b5b75 d055be4fdc562a8ecb8e6d0bf419f946 ea6a61e571a858aa6019ceb068ea403a

Email subscription for changes to this article
Save as PDF