Article ID: 6588, created on Aug 7, 2009, last review on May 10, 2014

  • Applies to:
  • Plesk 9.x for Linux/Unix


After installing or upgrading of Parallels Plesk Panel to 9.2 version on a SuSE installation, YaST no longer starts:

~# yast
//sbin/yast: line 27: //lib/YaST2/bin/yast2-funcs: No such file or directory
//sbin/yast: line 250: set_lang_from_sysconfig: command not found
//sbin/yast: line 279: check_ncurses: command not found
package yast2-qt is not installed
package yast2-gtk is not installed  
Something is wrong with the YaST user interface.



$PATH system variable is modified during psa-courier-imap package installation in a way, that double slashes (//) are included. YaST is not able to interpret double slashes in the $PATH system variable, and crashes. 


This is a known issue, that will be fixed in a future version of Parallels Plesk Panel. As of now, a workaround is available, consisting of replacing double slashes (//) with a single slash (/) in the $PATH system variable, and eliminating any repeated paths. For example:

PATH = /usr/kerberos/sbin:/usr/kerberos/bin://sbin://bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin

should be replaced with:

PATH = /usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin

Also, be sure to install the missing packages, that are seen on the error message. In the example we use, it is yast2-qt and yast2-gtk.

6ef0db7f1685482449634a455d77d3f4 a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF