Article ID: 6594, created on Aug 7, 2009, last review on May 10, 2014

  • Applies to:
  • Plesk Billing


You get error message when trying to use Modernbill v4 license:

NOT OK (Your license key is not valid for this version of ModernBill. Please generate a new license key.)


This usually means you have very old Modernbill version or your system was moved from one server to another. To get this issue fixed you need to perform upgrade to the latest v4.4.2 version.

Please contact support to obtain the distribution files.

Upgrade instructions

Please, backup you fileset and database prior to upgrade.

Make sure your system meets all requirements

Note, you cannot upgrade directly from 4.0.2 to either the latest v4.
Here is the upgrade path:

4.0.2 to 4.1.5
4.1.5 to 4.4.2

Once upgrade is finished, login to the members area and copy your license key to newkey.php file and place this file in the root of Modernbill directory. Follow instructions on the login page.

08b3edb77202fffdd656b40acff117c1 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF