Article ID: 6990, created on Dec 9, 2009, last review on Aug 12, 2014

  • Applies to:
  • Plesk for Linux/Unix

Symptoms

The current version of phpMyAdmin in Parallels Plesk Panel is 2.8.2.4. It was released on August 22, 2006. How do I update phpMyAdmin to version 2.11.9.5?

Resolution

A ZIP archive with a patched version of phpMyAdmin-2.11.9.5-all-languages and a script for migrating settings from phpMyAdmin-2.8.2.4 installed with Parallels Plesk Panel is attached.
You may use the following instructions to install phpMyAdmin 2.11.9.5.

1. Download the archive and unpack it.

~# wget http://kb.sp.parallels.com/Attachments/11632/Attachments/phpMyAdmin.zip
~# unzip
phpMyAdmin.zip
~# ls phpMyAdmin
migrate_settings.sh 
phpMyAdmin-2.11.9.5-all-languages.tar.gz 
phpmyadmin.patch
~#


2. Extract the patched phpMyAdmin archive:

~# cd phpMyAdmin
~# tar -xzf phpMyAdmin-2.11.9.5-all-languages.tar.gz

3. Migrate the settings from the installed phpMyAdmin to the new one:

~# cd phpMyAdmin-2.11.9.5-all-languages && ../migrate_settings.sh

4. Back up the files of the installed phpMyAdmin (you can remove the old phpMyAdmin later):

~# mv /usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin /usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin.old

5. Move the files of the new phpMyAdmin to the Parallels Plesk Panel root directory:

~# cd ..
~# mv phpMyAdmin-2.11.9.5-all-languages /usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin

Attachments

a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF