Article ID: 8211, created on Mar 17, 2010, last review on May 10, 2014

  • Applies to:
  • Plesk for Windows


Parallels Panel is installed on Windows 2008 x64.

When some feature of a web-site has been opened via Internet Information Services 7.0 Manager, the following error arised:

There was an error performing this operation. 


The problem is that when the runtime tries to load the corresponding configuration, it does not take the bit-ness of the application pool into the consideration.  ASP.NET 1.1 is only supported on 32-bit.  So if a 64-bit OS is used, in order to run ASP.NET 1.1, it is necessary to enable 32-bit applications in the application pool.  So, with the QFE/SP2 on 64-bit OS (and only on 64-bit OS), the runtime is incorrectly looking for the 1.1 version of the configuration under Framework64, which does not exist.

If ASP.NET 1.1 is already installed on the 64-bit Windows, it is possible to workaround the case by coping of 32-bit configuration file as a 64-bit one:

1. Create the Framework64 directory for the 1.1 ASP.NET:
md %windir%\\framework64\v1.1.4322\config\

2. Copy the 32-bit configuration file to the created path:
copy %windir%\\framework\v1.1.4322\config\machine.config %windir%\\framework64\v1.1.4322\config\

85a92ca67f2200d36506862eaa6ed6b8 a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF