Article ID: 822, created on Oct 6, 2008, last review on May 6, 2014

  • Applies to:
  • Plesk for Linux/Unix

Resolution

Full error message:

Unable to make action: Unable to manage service by spamd: Empty error message from utility. 0: /usr/local/psa/admin/htdocs/server/restart_services.php:19 psaerror(string "Unable to make action: Unable to manage service by spamd: Empty error message from utility.")


Try to start psa-spamassassin from the command line:


/etc/init.d/psa-spamassassin start
Can't locate Text/Iconv.pm in @INC (@INC contains:
/usr/local/lib/perl5/5.8.7/i686-
linux /usr/local/lib/perl5/5.8.7
/usr/local/lib/perl5/site_perl/5.8.7/i686-linux
/usr/local/lib/perl5/site_perl/5.8.7 /usr/local/psa/lib/perl5/5.8.7
/usr/local/psa/lib/perl5/5.8.7/i686-linux
/usr/local/psa/lib/perl5/site_perl/5.8.7/i686-linux
/usr/local/psa/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.0
/usr/local/lib/perl5/site_perl) at
/usr/lib/perl5/site_perl/5.8.0/Mail/SpamAssassin/CmdManage.pm line 8.
BEGIN failed--compilation aborted at
/usr/lib/perl5/site_perl/5.8.0/Mail/SpamAssassin/CmdManage.pm line 8.
Compilation failed in require at /usr/local/psa/admin/sbin/spammng line 71.


This error means that there is something wrong with Perl itself because it cannot find all needed modules. Make sure that all RPMs required for 'Spamassassin' are installed.

Check Perl version:

perl -v
rpm -q perl


And package integrity with the command:

rpm -V perl


Reinstall Perl RPM if versions which are shown by these commands don't match or integrity test shows any errors.

a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF