Article ID: 9067, created on Sep 24, 2010, last review on Aug 12, 2014

  • Applies to:
  • Plesk 9.x for Linux/Unix

Symptoms

Parallels Plesk Panel version 9.5.x is running with Postfix MTA.
Mail is not accepted from the server even if its ip address is listed at the White list. (Settings -> Mail server settings -> White list tab).

Only 3 networks are listed at the mail configuration file, even if more than 3 networks are added from the Control Panel. Only last 3 networks were added to the configuration file.
# grep ^mynetworks /etc/postfix/main.cf
mynetworks = 127.0.0.0/8, 192.168.0.100/32, 100.0.0.1/24

Cause

This issue occurs if more then 2 IP addresses are configured on the server.

Resolution

Hotfix should be applied on the server if issue occurs on your server.
Hotfix is available for Debian 5 x64. It can be applied on the server with Parallels Plesk Panel version 9.5.x

For applying hotfix replace the file $PRODUCT_ROOT_D/admin/sbin/mailmng with the file from the attachment.
Then add one more network into the white list. Postfix configuration will be updated.

Please read article #8083 about a hot-fix installation procedure.

If you need hotfix for another OSes, please contact technical support.

Attachments

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