Article ID: 9208, created on Oct 25, 2010, last review on May 9, 2014

  • Applies to:
  • Plesk 9.x for Linux/Unix

Symptoms

Migration of client and domain from Parallels Plesk Panel 7.5.4 to Parallels Plesk Panel 9.3 fails with error:

 <?xml version="1.0"?>
<execution-result status="error"><message code="InternalDtdValidationFailed" severity="error"><context>void plesk::validateSchema(plesk::tXmlDocument&, const std::string&)</context><file>./xml_parse.cpp</file><line>412</line><text>Failed validation of the document with its internal DTD. The errors are: Element 'mailuser': The attribute 'guid' is required but missing.Element 'mailuser': The attribute 'guid' is required but missing.Element 'mailuser': The attribute 'guid' is required but missing.Element 'mailuser': The attribute 'guid' is required but missing.Element 'mailuser': The attribute 'guid' is required but missing.Element 'mailuser': The attribute 'guid' is required but missing.Element 'mailuser': The attribute 'guid' is required but missing.Element 'mailuser': The attribute 'guid' is required but missing.Element 'mailuser': The attribute 'guid' is required but missing.Element 'mailuser': The attribute 'guid' is required but missing.Element 'mailuser': The attribute 'guid' is required but missing..</text></message></execution-result>

Cause

guid is missing in dump created with migration agent of Plesk 9.3.
Also the guid is not generated/added into dump during migration:
 
# pwd
/usr/local/psa/PMM/msessions/20100720181814804
# grep guid *
#

Resolution

The problem has been fixed in Parallels Panel since version 9.5.0. In order to resolve the problem it is recommended that you upgrade.

6ef0db7f1685482449634a455d77d3f4 a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF