Article ID: 9628, created on Feb 1, 2011, last review on May 8, 2014

  • Applies to:
  • Virtuozzo containers for Linux 4.6
  • Virtual Automation 4.6

Additional information

For instructions on how to install the PVA agent to a different environment, please follow this article:

9445 - How to install/reinstall/upgrade to PVA 4.6 Agent on a PVC 4 for Linux HW Node

Symptoms

PVA 4.6 agent installation fails with the following error in the PVA log file on Redhat/CentOS 5.5/5.6 HW Nodes:

[ERROR] rpm_error_handler at ../lib/RedHatPackageHelper.cpp:371, Dependency check failed:
    pva-pp-httpd is needed by pva-pp-engine-4.6-210.43.x86_64

Resolution

The issue is planned to be fixed in future versions.

Workaround:

1. Replace the release information in the release file:

# mv /etc/redhat-release{,~}
# echo 'Red Hat Enterprise Linux Server release 5.4 (Tikanga)' > /etc/redhat-release
# ./pva-setup-deploy.x86_64
...

2. Follow the general installation instructions from this article:

9445 - How to install/reinstall/upgrade to the PVA 4.6 Agent on a PVC 4 for Linux HW Node

3. Restore the old release information in the release file:

# mv -f /etc/redhat-release{~,}

36627b12981f68a16405a79233409a5e d02f9caf3e11b191a38179103495106f e8e50b42231236b82df27684e7ec0beb d16a8794b3bdb3f66571d469e71906a9 319940068c5fa20655215d590b7be29b 2897d76d56d2010f4e3a28f864d69223

Email subscription for changes to this article
Save as PDF