Article ID: 113179, created on May 21, 2012, last review on May 11, 2014

  • Applies to:
  • Plesk 11.0 for Windows
  • Plesk 10.4 for Windows

Resolución

Usted puede configurar soporte para PHP 5.3 en Parallels Plesk Panel 10.4.4 mediante el autoinstaller: Herramientas y configuración > Actualizaciones

En el autoinstaller, seleccione "Añadir componente" y, en el grupo "Prestaciones de hosting de Parallels Plesk Panel" seleccione "Motor de script PHP5.3."




También puede configurar soporte para PHP 5.3 mediante el siguiente comando:
"%plesk_bin%\ai.exe" --select-release-id PANEL_10_4_4_WIN --install-component php53
Puede habilitar soporte para PHP 5.3 para un dominio en la Configuración de hosting del dominio:



Puede crear un dominio con PHP 5.3 usando el siguiente comando:
"%plesk_dir%\bin\domain.exe --create mydomain.name -hosting true -hst_type phys -clogin admin -login ftpuser1 -passwd s$kr3t -ip 10.52.76.75 -php true -php_version 5.3
Puede habilitar el soporte para PHP 5.3 para un dominio existente usando el siguiente comando:
"%plesk_dir%\bin\domain.exe --update mydomain.name -php true -php_version 5.3
Asimismo, puede definir el soporte para PHP 5.3 para los dominios en el plan de servicio:



Puede crear un plan de servicio con soporte para PHP 5.3 mediante el siguiente comando:
service_plan.exe --create newplan -php true -php_version 5.3

En el caso de un plan de servicio existente, el soporte para PHP 5.3 puede habilitarse mediante el siguiente comando:
service_plan.exe --update "Default Domain" -php true -php_version 5.3
Todas las acciones mencionadas anteriormente pueden ejecutarse mediante peticiones API-RPC. Por ejemplo:
<packet version="1.6.3.0">
<site>
<set>
<filter>
<name>mysite.name</name>
</filter>
<values>
<hosting>
<vrt_hst>
<property>
<name>php_version</name>
<value>5.3</value>
</property>
</vrt_hst>
</hosting>
</values>
</set>
</site>
</packet>

Información adicional

- El parámetro date.timezone está configurado a UTC en %plesk_dir%\Additional\PleskPHP53\php.ini.
- El soporte para operaciones PHP como ISAPI fue desactivado en la versión 5.3 de PHP. En Parallels Plesk Panel, PHP 5.3 funciona en modo CGI o FastCGI.
- Si Parallels Plesk Panel fue instalado con Microsoft SQL Server 2005, para un correcto funcionamiento de la extensiones PHP sqlsrv y sqlpdo, también deberá instalar MS SQL Server 2008 Native Client en el servidor Parallels Panel.

56797cefb1efc9130f7c48a7d1db0f0c ff5a00b8ead2e480367b019417a04207 a914db3fdc7a53ddcfd1b2db8f5a1b9c 85a92ca67f2200d36506862eaa6ed6b8 c796c01d6951fa24ed54c7f1111667c6 514af229ae32522202a910a2649c80fb bd7fc88cf1b01f097749ae6f87272128

Email subscription for changes to this article
Save as PDF