Article ID: 113424, created on Mar 9, 2012, last review on Aug 12, 2014

  • Applies to:
  • Plesk 10.x for Linux
  • Plesk 9.x for Linux/Unix
  • Plesk 8.x for Linux/Unix
  • Plesk 10.x for Windows
  • Plesk 9.x for Windows
  • Plesk 8.x for Windows

Notas de la versión

El script plesk_remote_vulnerability_checker.php permite a los propietarios de Parallels Panel averiguar si su servidor con Parallels Plesk Panel 8.x, 9.x, 10.0, 10.1, 10.2 o 10.3 es vulnerable.

[descargar el script]

Uso:
Cambie el directorio por el directorio donde ha descargado el script y ejecute el comando que aparece a continuación para iniciarlo.

Linux:
# php -d safe_mode=0 plesk_remote_vulnerability_checker.php


Windows:
"%plesk_dir%\additional\PleskPHP5\php.exe" -d safe_mode=0 plesk_remote_vulnerability_checker.php

La salida de este script será una de las siguientes:

1. The patch has been successfully applied − si las correcciones recomendadas han sido instaladas.
2. The file <missed file name> has not been found. The patch is not applicable − si los archivos de destino no se encuentran en el servidor.
3. The patch has not been applied − si las correcciones recomendadas no han sido instaladas.
4. The file <version file name> has not been found − si el archivo de versión de Parallels Plesk Panel no ha sido encontrado.
5. Failed to get Plesk version from <version file name> − si la versión de Parallels Plesk Panel está dañada.
6. Plesk is up to date − si está usando Parallels Plesk Panel 10.4.x.

Si la salida es "The patch has not been applied," consulte este artículo para descubrir cómo aplicar el parche.

Attachments

56797cefb1efc9130f7c48a7d1db0f0c aac4a8fcd879de03758354e15495d69a a914db3fdc7a53ddcfd1b2db8f5a1b9c 85a92ca67f2200d36506862eaa6ed6b8 c796c01d6951fa24ed54c7f1111667c6 c45acecf540ecd42a4bbfb242ce02b1d b8ef5052d936e902043e41759118114e 29d1e90fd304f01e6420fbe60f66f838 dd0611b6086474193d9bf78e2b293040 6ef0db7f1685482449634a455d77d3f4

Email subscription for changes to this article
Save as PDF