Article ID: 113604, created on Oct 1, 2012, last review on Aug 12, 2014

  • Applies to:
  • Plesk 12.5 for Windows

Síntomas

Puede experimentar distintos síntomas:

-          Error en la actualización principal/secundaria
-          Los servicios no pueden iniciarse
-          Los servicios no funcionan correctamente
-          Errores en el panel de control
-          Errores durante la migración/backup

Causa

La instalación de Parallels Plesk Panel puede haber sufrido una actualización incorrecta.
 
Declinación de responsabilidades: Aunque sólo existe una causa posible, es importante identificarla en la fase inicial de la resolución del problema antes de realizar cualquier cambio en el servidor. De lo contrario, puede resultar difícil restaurar la instalación a una condición de trabajo.

Diagnóstico

Nota: Si existen múltiples servicios que no pueden iniciarse o funcionan de forma incorrecta, compruebe si dispone de suficiente espacio en disco en todas las particiones del disco.
 
Es necesario verificar que todos los componentes de Parallels Plesk Panel pertenecen a la misma versión, por lo que los comprobaremos uno a uno.
 
La propia instalación:

# cat /usr/local/psa/version
10.4.4 CentOS 5 1013111102.18

Nota: En el caso de sistemas como Debian, suele ser "/opt/psa/version."

Base de datos PSA:
# mysql -uadmin -p`cat /etc/psa/.psa.shadow` -D psa -e 'select * from upgrade_history order by upgrade_date desc limit 1'
+---------------------+--------------+------------+
| upgrade_date        | version_info | db_version |
+---------------------+--------------+------------+
| 2012-03-30 12:48:00 |       10.4.4 |     10.4.4 |
+---------------------+--------------+------------+

Nota: Si no ve ninguna salida, esto significa que su base de datos nunca ha sido actualizada.

Paquetes:
# rpm -q psa
psa-10.4.4-cos5.build1013111102.18

Nota: En el caso de sistemas como Debian, puede ser necesario utilizar el comando “dpkg –l psa”.
 
Análisis de los resultados:

Si las versiones devueltas arriba no coinciden, esto significa que anteriormente su instalación de Parallels Plesk Panel ha sufrido una actualización con errores. En este caso, examine la sección Resolución de este artículo.
Si todas las tres versiones coinciden y usted estaba actualizando a la versión 10 desde una versión anterior de Parallels Plesk Panel, puede aplicar la resolución detallada en este artículo.

Resolución

Intente encontrar el motivo del error en la actualización examinando el archivo de registro del Autoinstaller:

/tmp/autoinstaller3.log
 
A continuación, busque el mensaje de error en nuestra base de conocimiento.

Si no encuentra ningún tipo de información útil en los registros, puede que sea necesario habilitar el registro de depuración tal y como se describe en el artículo:

1139
Cómo habilitar el registro de depuración para el AutoinstallerSi estas acciones no consiguen resolver el problema, utilice cualquiera de las opciones de soporte disponibles detalladas en el portal de soporte (en el menú que se muestra a la izquierda).

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