Article ID: 113995, created on Jun 14, 2012, last review on Aug 12, 2014

  • Applies to:
  • Odin Business Automation Standard 4.5
  • Odin Business Automation Standard 4.0
  • Plesk 11.5 for Linux

Síntomas

Un nodo Parallels Plesk Panel (Plesk) está operativo y en ejecución pero en el panel de Parallels Business Automation - Standard (Arriba > Director de servicios > Administrador de Plesk > Nodos) este muestra el estado "No disponible".

Causa

Existen varias incidencias que pueden ocasionar este problema, entre las que se incluyen las siguientes:

  • Incidencias de conectividad de red
  • La licencia de Plesk ha expirado
  • La contraseña del administrador de Plesk ha sido modificada directamente a través del panel de control de Plesk
  • La dirección IP del nodo PBA-S ha sido modificada
  • Corrupción del paquete API-RPC en Plesk

Resolución

  1. Compruebe que Plesk funciona correctamente tal y como se detalla en los siguientes artículos para Parallels Plesk para Linux o para Parallels Plesk para Windows

  2. Acceda al panel de control de Plesk y compruebe que tiene instalada una licencia válida.

  3. Compruebe que desde el servidor PBA-S puede accederse a la dirección IP del servidor Plesk y que la conexión al puerto 8443 no está bloqueada en el servidor Plesk ni en el servidor PBA-S.

    Para comprobar la conexión de PBA-S, acceda al servidor PBA-S mediante SSH. Verifique la conexión del servidor Plesk (IP 123.123.123.10 ) en el puerto 8443 con el comando telnet:

    # telnet 123.123.123.10 8443
    Trying 123.123.123.10...
    Connected to 123.123.123.10.
    Escape character is '^]'.
    
  4. Obtenga la contraseña admin para Parallels Plesk para Linux o para Parallels Plesk para Windows y actualícela en PBA-S:

    Arriba > Director de servicios > Administrador de Plesk > Nodos > %nodo Plesk% > Editar > Contraseña del administrador de Plesk

    Esta acción reiniciará las claves seguras para las futuras comunicaciones. NOTA: la conexión puede resultar fallida debido a la directiva de seguridad de Plesk.

  5. Ejecute la tarea periódica "Actualizar info estadística de nodos Plesk" a través del panel de control del proveedor de PBA-S para así actualizar el estado del nodo Plesk:

    Arriba > Director de configuración > Registro y errores > Registro de acciones > pestaña Cola de tareas > Actualizar info estadística de nodos Plesk  > Ejecutar ahora

    Verifique el registro DEBUG de PBA-S para examinar los registros de actualización. NOTA: la tarea puede resultar fallida debido al error "PleskAPIInvalidSecretKeyException : Invalid secret key usage. Please check logs for details."

  6. Por diseño, PBA-S se comunica con Plesk mediante la API de Plesk. Compruebe la coherencia de los paquetes relacionados con API-RPC en el servidor Plesk:

    • Linux

    Valide el paquete psa-api-rpc:

    # rpm -V psa-api-rpc
    

    Este comando le proporcionará una lista de los archivos ausentes o modificados, de existir. Si la salida no está en blanco, lo más probable es que deba reinstalar el paquete.

    El paquete válido puede obtenerse en http://autoinstall.plesk.com (conforme a la versión de Plesk, el SO y la arquitectura) y proceder con la reinstalación. El ejemplo que se muestra a continuación ilustra la instalación del paquete psa-api-rpc de Plesk 11.5.30 instalado en un servidor con CentOS 6 x64.

    # wget http://autoinstall.plesk.com/PSA_11.5.30/dist-rpm-CentOS-6-x86_64/contrib/psa-api-rpc-10.0.0-1.noarch.rpm
    # rpm -Uvh --force psa-api-rpc-10.0.0-1.noarch.rpm
    

    Una vez haya reinstalado el paquete, ejecute de nuevo la tarea "Actualizar info estadística de nodos Plesk" en PBA-S, tal y como se detalla en el paso 4.

    • Windows

    No existe ningún método rápido de reinstalar un único paquete en Windows. Los archivos en cuestión se encuentran en el directorio %plesk_dir%\admin\plib\api-rpc.

    Examine que los archivos presentes en este directorio, concretamente Agent.php, no se modificaron tras la instalación/actualización y que estos tienen los permisos correctos:

    psaadm: Read, Read&execute
    

70a5401e8b9354cd1d64d0346f2c4a3e caea8340e2d186a540518d08602aa065 400e18f6ede9f8be5575a475d2d6b0a6 a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c 29d1e90fd304f01e6420fbe60f66f838 fc8d1cb26534a6b898faa9daa73bd86e 624ca542e40215e6f1d39170d8e7ec75 01bc4c8cf5b7f01f815a7ada004154a2 0a53c5a9ca65a74d37ef5c5eaeb55d7f

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