Article ID: 114071, created on Jan 16, 2015, last review on Apr 28, 2015

  • Applies to:
  • Plesk 12.5 for Windows
  • Plesk 12.0 for Windows
  • Plesk 11.0 for Windows
  • Virtuozzo 6.0
  • Virtuozzo containers for Linux 4.7
  • Virtuozzo containers for Windows
  • Virtuozzo hypervisor

Síntomas

  1. El servicio WAS y los servicios que dependen de este (IIS y Plesk) no funcionan en los contenedores.

  2. Cuando se inicia WAS, se obtiene el siguiente error:

    C:\Users\Administrator>net start was
    The Windows Process Activation Service service is starting.
    The Windows Process Activation Service service could not be started.
    
    A system error has occurred.
    
    System error 6801 has occurred.
    
    Transaction support within the specified resource manager is not started or was
    shut down due to an error.
    

Causa

Esta incidencia se experimenta cuando el registro de transacciones del sistema está dañado.

Resolución

Existen distintas formas de resolver el problema. Le recomendamos aplicarlas en el orden detallado a continuación. Por ejemplo, si la primera solución no le ayuda a solucionar el problema, pruebe a aplicar la segunda solución y así consecutivamente.

Primera solución

Intente realizar los pasos descritos en el siguiente artículo de Microsoft:

IIS services fail to start: "Windows could not start the Windows Process Activation Service - Error 6801: Transaction support within the specified resource manager is not started or was shut down due to an error" when WAS service is started

  1. Emita el siguiente comando en el símbolo del sistema del contenedor

    fsutil resource setautoreset true c:\
    

    Nota: damos por sentado que la unidad del sistema es la "C:"

  2. Una vez ejecutado el comando, reinicie el contenedor.

Segunda solución

Si sigue experimentando el problema una vez realizadas estas acciones, puede que le ayude a solucionarlo el hecho de clonar un contenedor.

NOTA: en los comandos que puede ver a continuación, incluya los IDs actuales del contenedor y la ubicación de la carpeta VZ y ejecute los comandos en el símbolo del sistema:

  1. Detenga en contenedor:

    vzctl stop 101
    
  2. Cree un backup de los archivos de configuración del contenedor original:

    copy E:\vz\private\101\.vza\eid.conf 101.eid
    copy E:\vz\conf\101.conf 101.conf
    
  3. Clone el contenedor original a otro contenedor:

    vzmlocal -C 101:202
    
  4. Cambie el ID del contenedor anterior a otro ID:

    vzmlocal 101:100000
    
  5. Desactive el arranque automático para el contenedor original:

    vzctl set 100000 --save --onboot no
    
  6. Elimine la dirección IP del contenedor original:

    vzctl set 100000 --save --ipdel all
    
  7. Cambie el ID del contenedor para el nuevo contenedor al ID del contenedor anterior:

    vzmlocal 202:101
    
  8. Detenga PVA Agent:

    net stop pvaagent
    

    Cualquier operación de reemplazo de EID debería efectuarse con PVA Agent detenido.

  9. Elimine el archivo de caché del EID:

    del E:\vz\PVA\Agent\Data\etc\configs\EID
    

    Use la letra de disco correcta para los archivos de PVA Agent.

  10. Reemplace los EIDs:

    type E:\vz\private\101\.vza\eid.conf > E:\vz\private\100000\.vza\eid.conf
    type 101.eid > E:\vz\private\101\.vza\eid.conf
    
  11. Inicie PVA Agent para así volver a generar el EID <-> CTID bindings:

    net start pvaagent
    
  12. Inicie el contenedor resultante:

    vzctl start 101
    

Una vez haya verificado que el nuevo contenedor funciona correctamente, puede eliminar el contenedor anterior.

Tercera solución

Aplique esta solución si la segunda solución no le ayudó a resolver la incidencia o si al cabo de poco tiempo volvió a experimentarla. Esto suele suceder si el disco del contenedor está fragmentado y el contenedor siempre se inicia en modo infracción de uso compartido:

C:\Users\Administrator>vzctl start 101

Starting container...

WARNING: (C:\vz\Private\101\root.efd, {971890c5-833d-4857-86f7-17cc762bfda3}) sharing violation, trying nonpaged mount
Container is mounted
Container was started

En primer lugar, instale la corrección detallada en este artículo de nuestra base de conocimiento. Esto le ayudará a resolver la incidencia por infracción de uso compartido ocasionada por una elevada fragmentación del disco. Una vez completada la instalación y reiniciado el nodo, puede ser necesario volver a aplicar la segunda solución descrita anteriormente en este artículo.

A continuación, compruebe si en el nodo hardware se ha instalado un antivirus y si este está configurado correctamente. A veces, una sharing violation puede deberse a la existencia de un antivirus en un nodo hardware si el área privada del contenedor (X:\vz\private\) no se ha excluido de las actividades del antivirus. En este escenario, el antivirus bloquea el disco del contenedor (el archivo root.efd), por lo que no es posible un bloqueo exclusivo. Como resultado, los contenedores se ven forzados a iniciarse en modo compartido.

Para evitar este tipo de incidencias, excluya X:\vz\private\ de todas las actividades realizadas por el antivirus.

Información adicional

IMPORTANTE:

  • Si el contenedor ejecuta MSSQL Server, consulte el siguiente artículo de nuestra base de conocimiento:

116218 MSSQL no funciona en un contenedor clonado o tras una migración c2v

  • Si el contenedor es miembro de Active Directory (AD), consulte el siguiente artículo de nuestra base de conocimiento:

119018 Error de relación de confianza en clientes del dominio tras la migración/restauración del controlador del dominio

965b49118115a610e93635d21c5694a8 2897d76d56d2010f4e3a28f864d69223 d02f9caf3e11b191a38179103495106f a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c e8e50b42231236b82df27684e7ec0beb ed7be2b984f9c27de1d2dc349dc19c6d 85a92ca67f2200d36506862eaa6ed6b8 a766cea0c28e23e978fa78ef81918ab8 0c05f0c76fec3dd785e9feafce1099a9 514af229ae32522202a910a2649c80fb bd7fc88cf1b01f097749ae6f87272128 a26b38f94253cdfbf1028d72cf3a498b 8b661cab116c79dbe6c4ac5bbdf1c8cb 0dd5b9380c7d4884d77587f3eb0fa8ef c62e8726973f80975db0531f1ed5c6a2

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