Article ID: 114378, created on Jul 26, 2012, last review on Aug 12, 2014

  • Applies to:
  • Plesk 10.4 for Linux/Unix
  • Plesk 10.3 for Linux/Unix
  • Plesk 10.2 for Linux/Unix
  • Plesk 10.1 for Linux/Unix
  • Virtuozzo containers for Linux 4.7

Notas de la versión

Este artículo detalla las distintas correcciones para las vulnerabilidades más críticas presentes en las versiones anteriores de Parallels Plesk Panel, incluyendo la versión 8.x, 9.0.x - 9.5.5 y 10.0.x - 10.4.4 para Linux. Las versiones anteriores a las detalladas, como por ejemplo la versión 7.x o la 6.x, también deben actualizarse a una versión más reciente que no presente estas vulnerabilidades.

NOTA: estas correcciones están disponibles mediante las siguientes microactualizaciones:

8.6.0 MU#15

9.5.4 MU#21

10.0.1 MU#14

10.1.1 MU#23

10.2.0 MU#17

10.3.1 MU#18

10.4.4 MU#39

Resolución

  1. Cree un directorio temporal:

    # mkdir plesk_remote_vulnerability_fix_deployer
    
  2. Vaya al directorio creado:

    # cd plesk_remote_vulnerability_fix_deployer
    
  3. Descargue el archivo adjunto a este artículo (md5sum: 7589fba44bd3d5b8c5b5c430a86d79f7) y descomprímalo:

    # wget http://kb.sp.parallels.com/Attachments/kcs-23896/plesk_remote_vulnerability_fix_deployer.tar.gz
    # tar -xzf plesk_remote_vulnerability_fix_deployer.tar.gz
    
  4. Ejecute el siguiente comando desde el directorio temporal creado:

    # /usr/local/psa/admin/bin/php plesk_remote_vulnerability_fix_deployer.php
    

NOTA: para simplificar la realización de un despliegue masivo en un entorno Parallels Virtuozzo Containers (PVC) para Linux, le recomendamos utilizar el script plesk_remote_vulnerability_fix_mass_deployer:

  1. Cargue este archivo comprimido a otra carpeta del nodo hardware: plesk_remote_vulnerability_fix_mass_deployer.tar.gz (md5sum: 2dd4f90ca8f591814dd7d7d2cf2e8477)

  2. Descomprima el archivo:

    # tar -xzf plesk_remote_vulnerability_fix_mass_deployer.tar.gz
    
  3. Ejecute el script de shell como root:

    # ./plesk_remote_vulnerability_fix_mass_deployer.sh 
    

Específico para Parallels Plesk Expand

Si utiliza la versión 9.5.4 para Linux o la versión 9.5.4/9.5.5 para Windows, ambas gestionadas por Parallels Expand, debería instalar Parallels Plesk Panel 9.5.4 y Parallels Plesk Expand 2.3.2+ Compatibility Patch tras haber aplicado las microactualizaciones o las correcciones personalizadas.

Attachments

56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c e8e50b42231236b82df27684e7ec0beb 2897d76d56d2010f4e3a28f864d69223 d02f9caf3e11b191a38179103495106f 29d1e90fd304f01e6420fbe60f66f838 e8756e9388aeca36710ac39e739b2b37 dd0611b6086474193d9bf78e2b293040 0c05f0c76fec3dd785e9feafce1099a9 f4ce8084cb23619ef5fe9428ecc388ea def31538ba607bde27398f48ab5956be d3c493291d6d9f66837ac7495dfea9ca

Email subscription for changes to this article
Save as PDF