Article ID: 115379, created on Feb 18, 2014, last review on Aug 12, 2014

  • Applies to:
  • Operations Automation 5.5
  • Operations Automation 6.0
  • Odin Business Automation Standard 4.5
  • Virtuozzo 6.0
  • Virtuozzo containers for Linux 4.7
  • Virtual Automation

Síntomas

No se puede crear un backup en un servidor remoto debido a un error parecido al siguiente:

Mensaje de error: 422 : Failed to connect to backup server: Can't connect: System errors : unauthorized request

Causa

La causa más probable de esta incidencia es que se esté abriendo un gran número de sesiones recurrentes en el nodo de almacenamiento de backups.

Resolución

  1. Acceda al shell del nodo de almacenamiento de backups.

  2. Envíe la siguiente petición de API XML de forma local, usando vzlcon tal y como se describe en este artículo:

    <packet id="2" version="4.0.0">
    <target>sessionm</target>
    <data>
    <sessionm>
    <list_sessions/>
    </sessionm>
    </data>
    </packet>
    

    O bien ejecute el siguiente comando:

    ~# echo "<packet><target>sessionm</target><data><sessionm><list_sessions/></sessionm></data></packet>" | /opt/pva/agent/bin/sendRequestViaTCP.pl local -
    
  3. Guarde la salida en un archivo de texto, por ejemplo sessions.txt.

  4. Calcule el número de sesiones. Por ejemplo:

    ~# strings sessions.txt | grep -c '<ns2:id>'
    

    Si el número es cercano a 20 o superior, será necesario aumentar el límite en el archivo de configuración de PVA Agent.

  5. Añada <user_session_limit>200</user_session_limit> a la sección sessionm en vzagent.conf para que así la sección resultante se parezca a la siguiente:

    <sessionm>
    <configuration>
    <user_session_limit>200</user_session_limit>
    <session_expiration>1200</session_expiration>
    <persistent_session_expiration>180</persistent_session_expiration>
    <inactive_session_expiration>30</inactive_session_expiration>
    </configuration>
    </sessionm>
    
  6. Reinicie PVA Agent.

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