Article ID: 116765, created on Dec 9, 2014, last review on Dec 11, 2014

  • Applies to:
  • Operations Automation 6.0
  • Plesk for Linux/Unix
  • Virtuozzo containers for Linux 4.7

Síntomas

La tarea de instalación de plantillas de Plesk resulta fallida y se obtiene el siguiente mensaje de error:

Internal error: 3501 : Can not install packages: ' vzpkg install -q 9200 .pp11.5-webmail .pp11.5-webhosting-addons .pp11.5-watchdog .pp11.5-spamassassin .pp11.5-postfix .pp11.5-php5 .pp11.5-bind .pp11.5-panel-addons .pp11.5-migration .pp11.5-mailman .pp11.5' exec failed - W: Failed to fetch http://autoinstall.plesk.com/debian/NGINX1.5/dists/wheezy/all/binary-amd64/Packages 404 Not Found

Causa

Las plantillas de aplicación pp*-nginx han quedado obsoletas, puesto que Nginx tiene su propio repositorio y otras plantillas de aplicación. Es por este motivo que deben eliminarse estas plantillas de aplicación.

Resolución

Elimine las plantillas de aplicación pp*-nginx del servidor para todas las distribuciones de SO y fuerce una actualización de los metadatos del servidor.

  1. Elimine las plantillas:

    ~# vzpkg list | awk '$2~/^pp.*-nginx$/{print$1" "$2}' | while read os app; do vzpkg remove template -F $os $app; done
    
  2. Actualice los metadatos que, en este caso, son para la plantilla de SO debian-7.0-x86_64:

    ~# vzpkg update metadata debian-7.0-x86_64 -r
    

a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c e8e50b42231236b82df27684e7ec0beb 2897d76d56d2010f4e3a28f864d69223 d02f9caf3e11b191a38179103495106f 29d1e90fd304f01e6420fbe60f66f838 5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 614fd0b754f34d5efe9627f2057b8642 0c05f0c76fec3dd785e9feafce1099a9 956c448bddc7e1f3585373687602379f 6f1456866eed87488c0f02b298a741c0

Email subscription for changes to this article
Save as PDF