Article ID: 119450, created on Feb 12, 2015, last review on Feb 12, 2015

  • Applies to:
  • Virtuozzo
  • Virtuozzo hypervisor

Síntomas

La máquina virtual no se inicia debido al mensaje de error BOOTMGR is missing.

Causa

Entre las causas más comunes de la aparición de errores BOOTMGR se incluyen la presencia de archivos corruptos y configurados de forma errónea, incidencias de actualización del sistema operativo y del disco duro, existencia de sectores dañados del disco duro, etc.

Otro caso es cuando la máquina virtual intenta iniciarse a través de un disco duro o de una imagen/unidad de CD o DVD que no está debidamente configurada para dicha finalidad.

Resolución

  1. Compruebe el orden de inicio establecido para la máquina virtual. Asimismo, verifique que el disco duro virtual correcto aparece en primer lugar y que este está activado.
  2. Cambie el tipo de interfaz para el disco duro virtual (IDE -> SATA o SATA -> IDE) e intente iniciar la máquina virtual de nuevo.
  3. Inicie la máquina virtual mediante un disco de instalación de Windows. Seleccione la opción Reparar el equipo. En las opciones de recuperación, escoja Símbolo del sistema.

    Copie el archivo bootmgr del disco de instalación a la partición del sistema:

    • Utilice la herramienta DISKPART para encontrar las letras para todos los discos:
       

    • Cambie el directorio al medio de instalación:

      cd E:
      
    • Copie bootmgr (use la letra correcta obtenida en la salida de diskpart):

      copy bootmgr C:\   
      
    • Use la herramienta bootrec.exe para completar el proceso de reparación:

      bootrec.exe /fixmbr
      bootrec.exe /fixboot
      bootrec.exe /rebuildbcd
      

a26b38f94253cdfbf1028d72cf3a498b 2897d76d56d2010f4e3a28f864d69223 0dd5b9380c7d4884d77587f3eb0fa8ef

Email subscription for changes to this article
Save as PDF