Article ID: 120621, created on Nov 27, 2014, last review on Nov 27, 2014

  • Applies to:
  • Operations Automation 5.5
  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 10.4 for Linux/Unix
  • Plesk 12.5 for Windows
  • Plesk 11.0 for Windows
  • Plesk 11.5 for Windows

Síntomas

No se puede eliminar una dirección IP en Herramientas y configuración > Dirección IP.

Se obtiene el siguiente error:

Error: La dirección IP <ip> no puede eliminarse porque está siendo usada por la zona DNS de uno o más dominios

Causa

La causa del problema es una incoherencia en la base de datos psa.

Resolución

  1. Cree un backup de la base de datos psa actual:

    Windows: "%plesk_dir%\MySQL\bin\mysqldump.exe" -uadmin -P8306 -p<PleskPasswordHere> psa > c:\psadump.sql
    
    Linux: mysqldump -uadmin -p`cat /etc/psa/.psa.shadow ` psa > /tmp/psa.`date +%F_%H.%M`.sql
    
  2. Busque los dominios cuyas zonas DNS impidan la eliminación de la dirección IP:

    mysql> set @ip_address := '101.10.10.10';
    mysql> select d.name as DomainName, dnsr.type, dnsr.host, dnsr.id as DNS_record_ID from domains as d join dns_recs as dnsr on d.dns_zone_id=dnsr.dns_zone_id  where dnsr.val=@ip_address;
    
  3. Para cada uno de los dominios detallados en la salida, vaya a Parallels Plesk > Dominios > example.com > Administrar hosting > Sitios web y dominios > Configuración DNS y elimine el registro correspondiente.

    Si el dominio no existe en Parallels Plesk, elimine el registro de forma manual usando el valor DNS_record_ID correspondiente de la salida.

    Por ejemplo, si example.com no existe:

    +-------------------------------+------+----------------------------------------+---------------+
    | DomainName                    | type | host                                   | DNS_record_ID |
    +-------------------------------+------+----------------------------------------+---------------+
    | test.tld                      | A    | mail.test.tld.                         |           358 |
    | example.com                   | A    | mail.example.com.                      |           134 |
    

    Ejecute el siguiente comando, comprobando que no elimina ningún registro para dominios activos:

    mysql> delete from dns_recs where id=134;
    

Si una vez cambiadas todas las suscripciones a una IP nueva sigue experimentando el problema, puede que los registros DNS no se hayan actualizado correctamente. En este caso, localice las entradas obsoletas en la tabla dns_recs:

mysql> SELECT * from `dns_recs` WHERE `val` = '<old_ip>';

Actualice todas las entradas. Para ello, debería modificarse la dirección IP anterior en val antes de proceder con la eliminación de esta IP.

Para corregir la representación visual en el interfaz web de Plesk, puede que sea necesario ejecutar la siguiente consulta:

mysql> UPDATE `dns_recs` SET `displayVal` = `val` WHERE `val` <> `displayVal`;

a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c 01bc4c8cf5b7f01f815a7ada004154a2 29d1e90fd304f01e6420fbe60f66f838 0a53c5a9ca65a74d37ef5c5eaeb55d7f 46a8e394d6fa13134808921036a34da8 85a92ca67f2200d36506862eaa6ed6b8 bd7fc88cf1b01f097749ae6f87272128 514af229ae32522202a910a2649c80fb 5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 5b048d9bddf8048a00aba7e0bdadef37 2554725ed606193dd9bbce21365bed4e 2a5151f57629129e26ff206d171fbb5f e335d9adf7edffca6a8af8039031a4c7 e8756e9388aeca36710ac39e739b2b37 dd0611b6086474193d9bf78e2b293040 aea4cd7bfd353ad7a1341a257ad4724a 614fd0b754f34d5efe9627f2057b8642 742559b1631652fadd74764ae8be475e 8b661cab116c79dbe6c4ac5bbdf1c8cb a766cea0c28e23e978fa78ef81918ab8

Email subscription for changes to this article
Save as PDF