Article ID: 121064, created on Feb 6, 2015, last review on Mar 9, 2016

  • Applies to:
  • Plesk for Linux/Unix

Síntomas

En el administrador de migraciones puede verse una notificación similar a la siguiente:

Los siguientes módulos de Apache no están instalados en el servidor de destino: `mem_cache`,`jk`,`bw`. Instale y habilite estos módulos para evitar posibles problemas.

¿Cómo puedo instalar y configurar los módulos Apache requeridos?

Resolución

Puede configurar módulos adicionales para el servidor web Apache de la siguiente forma:

  1. Compruebe la versión instalada del servidor web Apache:

    # rpm -qa | grep http
    httpd-2.2.15-30.el6.centos.x86_64
    
  2. Descargue las fuentes para la versión requerida de Apache y descomprímalas:

    # wget archive.apache.org/dist/httpd/httpd-2.2.15.tar.gz
    # tar xfz httpd-2.2.15.tar.gz   
    
  3. Instale los paquetes GNU compiller, C++ support to the compiller, kernel-developmenty httpd development:

    # yum install gcc gcc-c++ kernel-devel httpd-devel  
    
  4. Examine los archivos requeridos para la compilación de los módulos. Por ejemplo, encontrará información acerca del módulo mem_cache en el siguiente archivo:

    # cat /root/httpd-2.2.15/modules/cache/config.m4
    dnl #  list of object files for mod_mem_cache
    mem_cache_objs="dnl
    mod_mem_cache.lo dnl
    cache_cache.lo dnl
    cache_pqueue.lo dnl
    cache_hash.lo dnl
    
  5. Vaya a/root/httpd-2.2.15/modules/cache

    # cd /root/httpd-2.2.15/modules/cache
    
  6. Configure el módulo requerido ejecutando el siguiente comando:

    # apxs -c -i mod_mem_cache.c cache_cache.c cache_pqueue.c cache_hash.c
    

    Nota: el módulo mem_cache requiere otro módulo mod_cache. Este actúa como módulo de soporte para mod_cache y proporciona un administrador de almacenamiento basado en memoria. Plesk ofrece soporte integrado para mod_cache.

    Si desea más información, consulte la documentación oficial disponible aquí

  7. Reinicie el servidor web Apache para que se apliquen los cambios realizados en la configuración.

  8. A continuación, podrá gestionar los módulos Apache mediante el interfaz de Plesk Herramientas y configuración > Configuración de servidor web Apache

Nota: a partir de la versión 10.4, Plesk ofrece soporte integrado para mod_jk y mod_bw. Estos módulos pueden instalarse a través de Actualizaciones, concretamente en Limitador de ancho de banda para soporte para Apache (mod_bw) y Soporte para servlets Tomcat Java.

a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c 29d1e90fd304f01e6420fbe60f66f838

Email subscription for changes to this article
Save as PDF