Article ID: 123548, created on May 28, 2015, last review on May 28, 2015

  • Applies to:
  • Plesk for Linux/Unix

Síntomas

La instalación o actualización de Joomla no puede completarse debido al siguiente error:

Error: Unable to install the app because its installation requirements are not met. Contact your hosting provider to resolve this problem.
The app requires PHP 5.3.10 or later. Your PHP is 5.3.3. If PHP is not available, ensure that the PHP support is selected for the domain.

 

Resolución

En función de sus requisitos, realice una de las resoluciones detalladas a continuación:

  • Instale la versión anterior de joomla:

    a) En Dominios > domain.tld > Aplicaciones, abra la página joomla con la descripción de la aplicación.
    b) Haga clic en el enlace Seleccionar otra versión y seleccione la versión anterior.

  • Actualice la versión de PHP:

    a) En el caso de Plesk 12 en Centos 6/7 y Ubuntu 14, instale otra versión de PHP mediante el autoinstaller de Plesk.

    b) Actualice la versión de PHP a través del repositorio oficial usando yum install php

    c) Actualice la versión de PHP 3rd-partyusando repositorios de terceros:

    1. Atomic repository:
        # wget -q -O - http://www.atomicorp.com/installers/atomic | sh
    2. yum install php
    

    d) Actualice la versión de PHP compilando otra versión de PHP:

    1. Download the source of the required php version.
    
    2. Follow the http://kb.sp.parallels.com/en/118378 to make it available on the server.
    
  • Impida la instalación de la nueva versión de joomla y active la versión anterior de joomla que es compatible con la versión actual de PHP:

    1. Vaya a Herramientas y configuración > Inventario de aplicaciones > Mis apps > Añadir app
    2. Añadir joomla
    3. Haga que no esté disponible para los clientes
    4. Visite el catálogo APS
    5. Descargue la versión anterior de joomla que es compatible con su versión de PHP presente en el servidor.
    6. Vaya a Herramientas y configuración > Inventario de aplicaciones > Mis apps > Añadir app
    7. Seleccione la opción Upload an APS package
    8. Cargue el paquete descargado en el paso 5 haciendo clic en Browse.
    9. Haga que esta esté disponible para los clientes seleccionando la casilla Hacerlo disponible para los clientes.
    10. De esta forma solo podrá instalarse la versión anterior de joomla.

56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838

Email subscription for changes to this article
Save as PDF