Article ID: 1401, created on Mar 30, 2009, last review on Oct 3, 2014

  • Applies to:
  • Virtuozzo containers for Windows
  • Virtual Automation 6.0

Síntomas

  1. Al intentar crear un backup de un contenedor se obtiene el siguiente mensaje de error:

    Backup operation for node 'vz' failed: Failed to backup partition
    Acronis Error: Module=7 Code=33, "Unable to create volume snapshot"{=0}, Tag=0
    Acronis Error: Module=10 Code=0{=0}, Tag=f22447445b0f1f54
    
  2. Los demás contenedores pueden copiarse sin ningún tipo de problema.

  3. En C:\vzlog\YYYYMMDD-vzlog.log puede verse el siguiente error o bien errores similares acontecidos a la hora del error:

    {0000000248F3E0CF}; T=2014.04.10 12:57:56.339; A=fsresizer; P=20936.16644; S=VZSRV; F=build\4.6.490.0\sources\virtuozzo\vzwin\vzmain\vzdsklib\backup.cpp,VZVolumeSnapshot::ReadOriginalData,731; L=ERROR; R=ffff(65535); C=0(0); M=65535 [] ReadOriginalData - read error start=209640448, count=512, error=1
    {0000000248F3E0CF}; T=2014.04.10 12:57:56.339; A=fsresizer; P=20936.16644; S=VZSRV; F=build\4.6.490.0\sources\virtuozzo\vzwin\vzmain\vzdsklib\backup.cpp,VZVolumeSnapshot::ReadFromDriver,845; L=ERROR; R=ffff(65535); C=0(0); M=65535 [] ReadFromdriver::ReadOriginalData 2 failed, error=30
    {0000000248F3E0CF}; T=2014.04.10 12:57:56.339; A=fsresizer; P=20936.16644; S=VZSRV; F=build\4.6.490.0\sources\virtuozzo\vzwin\vzmain\vzdsklib\backup.cpp,VZVolumeSnapshot::Read,1034; L=ERROR; R=ffff(65535); C=0(0); M=65535 [] VZVolumeSnapshot::Read failed, start=209640448, count=512
    {0000000248F3E0CF}; T=2014.04.10 12:57:56.339; A=fsresizer; P=20936.16644; S=VZSRV; F=snapshot.cpp,SWVolumeSnapshot::IoOp,446; L=ERROR; R=ffff(65535); C=0(0); M=65535 [] OP_READ - begin:209640448 - size:512 - read:0
    

Causa

El disco duro virtual del contenedor (root.efd) puede estar dañado o bien este se encuentra en un bloque incorrecto del dispositivo de disco subyacente. Esto impediría la creación de la instantánea del disco virtual mediante la utilidad de creación de backups.

Resolución

  1. Compruebe el disco duro donde reside el contenedor y examine si existe algún error de hardware.
  2. Realice una verificación del sistema de archivos del contenedor.
  3. Si los pasos 1 y 2 no consiguen solucionar la incidencia, le recomendamos restaurar el contenedor mediante un backup.

965b49118115a610e93635d21c5694a8 d02f9caf3e11b191a38179103495106f 2897d76d56d2010f4e3a28f864d69223 0889ab60fa6494de107aa7338c3c38b6 319940068c5fa20655215d590b7be29b

Email subscription for changes to this article
Save as PDF