Article ID: 1658, created on Mar 19, 2009, last review on May 10, 2014

  • Applies to:
  • Plesk 11.5 for Linux

Síntomas

El servicio DrWeb devuelve el siguiente error de inicio:

Plesk authorization failed: HTTP request error [6]
Error: Plesk Software not running.


Causa

El paquete DrWeb incluido en la distribución de Parallels Plesk Panel está configurada para funcionar con el CP de Parallels Plesk panel, no pudiendo funcionar de forma autónoma. Este busca el CP de Parallels Plesk Panel en localhost:8443 para autorización y, si el intento resulta fallido, se muestra el error detallado en la sección anterior.


Resolución

Compruebe que el CP de Parallels Plesk Panel está ejecutándose en el puerto 8443 y que puede establecer una conexión a este puerto: 

#telnet localhost 8443
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.

Si obtiene el error que mostramos en este comando, el motivo puede ser:

- localhost no puede ser resuelto o se resuelve de forma incorrecta, por lo que deberá comprobar que la entrada localhost existe en /etc/hosts.

 127.0.0.1 localhost localhost.localdomain

- si aparece un error de conexión rechazada, intente iniciar Parallels Plesk Panel y compruebe que no hay ningún firewall ejecutándose en el servidor que pueda estar bloqueando el puerto 8443.

- compruebe también que Parallels Plesk Panel está configurado para ejecutarse en el puerto 8443, la directiva Listen 8443 debe estar presente en $PRODUCT_ROOT_D/admin/conf/httpsd.conf.

- compruebe que puede acceder al CP de Parallels Plesk Panel de forma normal a través de un navegador.

- finalmente, compruebe que Parallels Plesk Panel está respondiendo a la petición de DrWEB ejecutando el siguiente comando en el servidor Parallels Plesk Panel. Debería ser:

# curl -d "challenge=123&checker=drweb" https://localhost:8443/check-plesk.php -k
response=%7BS%D0%18%A5%F1%CF6Z%13%26%.....


 

 

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