Article ID: 1791, created on Apr 21, 2009, last review on Apr 17, 2012

  • Applies to:
  • Plesk for Linux/Unix

Síntomas

Si ejecuta la herramienta actualizadora desde el CP de Parallels Plesk Panel, obtiene el siguiente error:

     Warning: Error: Can't create directory //psa/.

De todas formas, esta herramienta funciona correctamente desde la línea de comandos.

Causa

Cuando ejecuta el actualizador desde el CP de Parallels Plesk Panel, este obtiene privilegios 'root' a través de la utilidad 'wrapper' que tiene definido el bit 'SUID'. Si el actualizador obtiene el error de permiso, lo más probable es que este no haya podido obtener estos privilegios 'root' debido a la ausencia del bit 'SUID'.

Resolución

Compruebe que el binario $PRODUCT_ROOT_D/admin/sbin/wrapper tiene los permisos adecuados tal y como detallamos a continuación:

# ls -la /usr/local/psa/admin/sbin/wrapper ---s--x---  1 root psaadm 13632 Jun 13  2006 /usr/local/psa/admin/sbin/wrapper
  
De lo contrario, corríjalo ejecutando el comando:
# chmod 4110 /usr/local/psa/admin/sbin/wrapper

Compruebe también que /usr/local/psa/admin/bin/autoinstaller es un enlace simbólico a /usr/local/psa/admin/sbin/wrapper :

# ls -la /usr/local/psa/admin/bin/autoinstaller
lrwxr-xr-x  1 root  psaadm  15 Jul 16 14:59 /usr/local/psa/admin/bin/autoinstaller -> ../sbin/wrapper


29d1e90fd304f01e6420fbe60f66f838 a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF