Article ID: 1862, created on Jun 25, 2009, last review on May 1, 2012

  • Applies to:
  • Sitebuilder 2.x for Linux/Unix

Causa

Lo más probable es que la versión de la API de los módulos no se haya definido correctamente en la base de datos de Parallels Plesk Sitebuilder.

Resolución

Compruebe que cada uno de los módulos tiene una versión de API correcta en la base de datos de Parallels Plesk Sitebuilder. Intente comprobarlo con la ayuda de las siguientes consultas:

Esta consulta muestra 'modules_api_version' (<VERSION>) de la configuración general de Parallels Plesk Sitebuilder:
 
mysql -usb_user -psb_user sitebuilder -e "select * from sb_settings where prop_name='modules_api_version';"

La siguiente consulta muestra la versión  'modules_api_version' de cada uno de los módulos:
 
mysql -usb_user -psb_user sitebuilder -e "select module_id,modules_api_version from sb_modules";

Si alguna versión de la API no es la misma para uno de los módulos, deberá actualizarla ejecutando el siguiente comando:
 
mysql -usb_user -psb_user sitebuilder -e "update sb_modules set modules_api_version=<VERSION>;"

<VERSION> - es la versión que obtiene en la primera consulta. En la mayoría de los casos <VERSION>=1.1.

Tenga en cuenta que el usuario 'sb_user' y la contraseña 'sb_user' son el usuario y la contraseña predeterminados para la base de datos MySQL. Generalmente, estas credenciales se encuentran en el archivo SITEBUILDER_ROOT/include/config.php: en los parámetros $sb_dbuser y $sb_dbpasswd.

f6788ae62f7286f419e5a6f078cc3361 d055be4fdc562a8ecb8e6d0bf419f946 fad6dc0c8e983c17ae70a51ac7952cd0 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF