Article ID: 2187, created on Mar 17, 2009, last review on May 4, 2014

  • Applies to:
  • Plesk 8.x for Linux/Unix
  • Plesk 7.5.x Reloaded

Resolución

La respuesta breve es 'no'. Para las aplicaciones web, Parallels Plesk Panel usa PHP que se carga como módulo DSO de Apache. Debido al espacio de nombres común, es muy difícil tener ambos módulos php4 y php5 en Apache de forma simultánea.

En general, las posibles soluciones para tener ambos PHP4 y PHP5 serían:

- ejecutar dos copias de Apache independientes, una para cada módulo PHP,
- ejecutar uno de los PHPs como módulo y el otro como CGI/suPHP
- compilar los módulos php con personalizaciones manuales especiales en las fuentes de los módulos para evitar su intersección.

Ninguna de estas opciones ha sido probada con Parallels Plesk Panel y ninguna de ellas está oficialmente soportada por las versiones actuales. Parallels Plesk Panel supone que el sistema tiene un paquete Apache estándar que carga un único módulo PHP estándar. Tenga en cuenta que ni PHP ni el servidor web Apache son partes del software Parallels Plesk Panel, este usa servicios estándar instalados en el servidor (en la mayoría de los casos se trata de paquetes estándar del fabricante del sistema operativo).

29d1e90fd304f01e6420fbe60f66f838 a914db3fdc7a53ddcfd1b2db8f5a1b9c b8ef5052d936e902043e41759118114e 097728dc0a325f6309aa7a3997d4cacc 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF