Article ID: 3546, created on Aug 4, 2009, last review on Apr 24, 2012

  • Applies to:
  • Plesk for Linux/Unix

Síntomas

La instalación o actualización de Parallels Panel en CentOS no puede completarse debido al siguiente error en la consola:

ERROR while trying to install initial Plesk database

Installation log shows:

Trying to install initial Plesk database... ERROR 1064 (42000) at
line 2: You have an error in your SQL syntax; check the manual that
corresponds to your MySQL server version for the right syntax to use near
'----------------------------------------' at line 1

Causa

La versión 5.0.54 de MySQL ya no acepta líneas con comentarios SQL que empiecen por '--' y que no tengan un espacio en blanco o un carácter de control después de la cadena '--'.  Esto funcionaba en las versiones anteriores de MySQL, aunque el equipo de MySQL afirmó explícitamente que no se soportaba (http://dev.mysql.com/doc/refman/5.0/en/ansi-diff-comments.html).

Resolución

Use los RPMs previos de mysql* del repositorio de centosplus, como por ejemplo http://mirror.centos.org/centos/4/centosplus/i386/RPMS/ y degrade MySQL a una versión anterior, como por ejemplo 5.0.48. Ejecute la instalación/actualización de Parallels Panel de nuevo. Esta incidencia será corregida en las próximas versiones de Parallels Plesk Panel.

29d1e90fd304f01e6420fbe60f66f838 a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF